Monday, 6 August 2007

VisionProject Multiple XSS vuln.

###############################################
Vuln. discovered by : r0t
Date: 7 August 2007
vendor:www.visionproject.se
affected versions:VisionProject 3.1 and previous
###############################################


VisionProject contains a flaw that allows a remote Cross-Site Scripting attacks.Input passed to the "projectIssueId" parameter in "EditProjectIssue.do"
and "projectId" parameter in "ProjectSelected.do" and "folderId" parameter in "ProjectDocuments.do" and "sortField" parameter in "ProjectIssues.do" isn't properly sanitised before being returned to the user.
This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of an affected site.

###############################################
Solution:
Edit the source code to ensure that input is properly sanitised.
###############################################

2 comments:

Tommy said...

These vulnerabilities have been fixed in VisionProject 3.2.

Thanks,
/Tommy Hellstroem
www.visionproject.se

Tommy said...

Hi,

The issue that you have on your site about "VisionProject Multiple Cross-Site Scripting Vulnerabilities" has been fixed since October 2007.

Regards,
/Tommy Hellstroem
www.visionproject.se